TL;DR
ディレクトリサービスにアクセスするための、TCP/IP ベースのプロトコル。
仕組み
プロトコルという名前だが、通信の手順だけでなく、システムが満たすべき動作の要件や、扱うデータの標準化されたモデルまで含む。それぞれの領域は、次の RFC で規定されている。
| 領域 | LDAP 標準の扱い | 根拠 |
|---|---|---|
| プロトコル(通信・操作) | 規定 | RFC 4511 |
| データの階層構造・情報モデル | 規定 | RFC 4512 |
| スキーマ(属性・objectClass) | 規定 | RFC 4519 |
| 認証(Bind・SASL・TLS) | 規定 | RFC 4513 |
注意点
SSO の文脈で出てくることが多いが、SSO のためのプロトコルではない。また、認可(アクセス制御、ACL)については規定がない。